CentOS6.5にPython3.6をインストール

cat /etc/issue
CentOS release 6.5 (Final)

CentOS6.5標準のPythonは2.6です。今(2017/06)から始めるのなら、3系にしたいと思って、3.6をインストールすることにしました。パッケージでは提供されていないので、ソースからビルドします。場所は/usr/local/配下で良いので、--prefixは未指定にしておきます。

$ wget https://www.python.org/ftp/python/3.6.1/Python-3.6.1.tgz
$ tar zxf Python-3.6.1.tgz
$ cd Python-3.6.1
$ ./configure
$ make
# make install

make installでエラーが出ました。

zipimport.ZipImportError: can't decompress data; zlib not available
make: *** [install] エラー 1

zlibはインストールされていたけど、zlib-develがインストールされていませんでした。下記でインストールして、再度make installしたら、無事Python3.6.1をインストールできました。

# yum install zlib-devel

トラブルシューティング

sqlite3をimportできない

以下のエラーが出て、sqlite3をimportできません。

$ python3 ./chatbot.py
Traceback (most recent call last):
  File "./chatbot.py", line 3, in <module>
    import sqlite3
  File "/usr/local/lib/python3.6/sqlite3/__init__.py", line 23, in <module>
    from sqlite3.dbapi2 import *
  File "/usr/local/lib/python3.6/sqlite3/dbapi2.py", line 27, in <module>
    from _sqlite3 import *
ModuleNotFoundError: No module named '_sqlite3'

sqlite-develをインストールして、その後再度Python3をビルドし直してインストールします。これで上記のエラーは出なくなりました。

yum install sqlite-devel.x86_64

Pythonのmakeの標準出力の最後に、取り込めなかった機能が表示されています。

The necessary bits to build these optional modules were not found:
_bz2                  _curses               _curses_panel
_lzma                 _ssl                  _tkinter

履歴

  • 2017/06/27 : bokupi 新規作成

トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: Wed, 28 Jun 2017 23:56:36 JST (169d)